Back to overview
Downtime

Server internal maintance

Dec 15 at 01:48am GMT-3
Affected services
Landing Site
API
Dashboard
Support Page
Server Main

Resolved
Dec 15 at 02:03am GMT-3

The scheduled maintenance has been completed. Thank you for your patience!

Updated
Dec 15 at 01:59am GMT-3

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Updated
Dec 15 at 01:55am GMT-3

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Created
Dec 15 at 01:48am GMT-3

Plenus will be performing routine maintenance. You may not be able to access https://plenus.one for a short period of time, but we’ll have things back up and running as soon as possible to minimize disruption to you.